@suzu6

主にWEBと解析の技術について書きます。

広く浅くも続ければ深くなるはず。

Nuxt2.5でのエラー:core-js/modules/es6.array.find in ./.nuxt/client.js

Nuxt 2.5.1にアップデートしてから、nuxt run devの実行時に表題のエラーが出たのでメモ。

環境

  • Nuxt v2.5.1
  • Node.js v11.12.0

エラー内容

コンパイル中にfriendly-errorsが山ほど出た。

$ nuxt run dev 

(省略)

friendly-errors 01:38:28  ERROR  Failed to compile with 35 errors

friendly-errors 01:38:28 These dependencies were not found:
friendly-errors 01:38:28 
friendly-errors 01:38:28 * core-js/modules/es6.array.find in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es6.array.iterator in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es6.date.to-string in ./.nuxt/utils.js
friendly-errors 01:38:28 * core-js/modules/es6.function.name in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es6.object.assign in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es6.object.keys in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es6.object.to-string in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es6.promise in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es6.regexp.constructor in ./.nuxt/utils.js
friendly-errors 01:38:28 * core-js/modules/es6.regexp.match in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es6.regexp.replace in ./.nuxt/utils.js, ./node_modules/babel-loader/lib??ref--2-0!./node_modules/vue-loader/lib??vue-loader-options!./components/common/ShareButtons.vue?vue&type=script&lang=js& and 1 other
friendly-errors 01:38:28 * core-js/modules/es6.regexp.search in ./.nuxt/utils.js
friendly-errors 01:38:28 * core-js/modules/es6.regexp.split in ./.nuxt/utils.js, ./node_modules/babel-loader/lib??ref--2-0!./node_modules/vue-loader/lib??vue-loader-options!./components/SideBar.vue?vue&type=script&lang=js& and 2 others
friendly-errors 01:38:28 * core-js/modules/es6.regexp.to-string in ./.nuxt/utils.js
friendly-errors 01:38:28 * core-js/modules/es6.string.includes in ./.nuxt/client.js, ./.nuxt/components/nuxt-link.client.js and 1 other
friendly-errors 01:38:28 * core-js/modules/es6.string.iterator in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es6.string.repeat in ./.nuxt/utils.js
friendly-errors 01:38:28 * core-js/modules/es6.string.starts-with in ./.nuxt/utils.js
friendly-errors 01:38:28 * core-js/modules/es6.symbol in ./.nuxt/client.js, ./.nuxt/components/nuxt-link.client.js
friendly-errors 01:38:28 * core-js/modules/es7.array.includes in ./.nuxt/client.js, ./.nuxt/components/nuxt-link.client.js and 1 other
friendly-errors 01:38:28 * core-js/modules/es7.promise.finally in ./.nuxt/client.js
friendly-errors 01:38:28 * core-js/modules/es7.symbol.async-iterator in ./.nuxt/client.js, ./.nuxt/components/nuxt-link.client.js
friendly-errors 01:38:28 * core-js/modules/web.dom.iterable in ./.nuxt/client.js, ./.nuxt/components/nuxt-link.client.js
friendly-errors 01:38:28 
friendly-errors 01:38:28 To install them, you can run: npm install --save core-js/modules/es6.array.find core-js/modules/es6.array.iterator core-js/modules/es6.date.to-string core-js/modules/es6.function.name core-js/modules/es6.object.assign core-js/modules/es6.object.keys core-js/modules/es6.object.to-string core-js/modules/es6.promise core-js/modules/es6.regexp.constructor core-js/modules/es6.regexp.match core-js/modules/es6.regexp.replace core-js/modules/es6.regexp.search core-js/modules/es6.regexp.split core-js/modules/es6.regexp.to-string core-js/modules/es6.string.includes core-js/modules/es6.string.iterator core-js/modules/es6.string.repeat core-js/modules/es6.string.starts-with core-js/modules/es6.symbol core-js/modules/es7.array.includes core-js/modules/es7.promise.finally core-js/modules/es7.symbol.async-iterator core-js/modules/web.dom.iterable
01:38:29 ℹ Waiting for file changes

最後の行に足りないパッケージをインストールするようにとあった。

$ npm install --save core-js/modules/es6.array.find core-js/modules/es6.ar...

実行したが解消しなかった。 また、$ yarn add core-jsも同様にダメだった。

Githubを確認

エラーを調べるとissues #3842に報告済みであり、クローズしていた。 依存関係にバグがありcore-jsの依存関係が解消されなかったらしい。

もう少しググる

解決策は(多分)無かったのでもう少しググり、中華サイトに行き当たった。 segmentfaultという中華版Stack OverFlowみたいなサイト。

解决liunx系统,项目nuxt2.0运行npm run dev / start报错问题

$ npm install --save core-js@latest2.6.2

最新版のcore-jsが必要そうなので、yarnで実行してみた。

$ yarn add core-js@latest2.6.2
yarn add v1.15.2
[1/4] Resolving packages...
Couldn't find any versions for "core-js" that matches "latest2.6.2"
? Please choose a version of "core-js" from this list: 2.6.5

core-jsの最新版の2.6.5を選択してインストールして解消した!!!

おわりに

まとまっていないのは申し訳ない。 悩まれている方の助けに少しでもなりますように。